OldsPower.com  

Go Back   OldsPower.com > Discussion > The Lounge
Register Forums Gallery Support Us! FAQ Mark Forums Read

Help Support OldsPower.com
Reply
 
Thread Tools Rate Thread
Old 12-05-2011, 04:09 PM   #1
Bradbutlernc

Title: Banned
Status: Offline
Join Date: Aug 2010
Location: Nashville, NC
Posts: 1,666
Default Kenwood KL 888X home tower 5 way speaker only playing woofer

I have 4 of these in my shop so i can have a little music while working, ran off a big 4 channel pioneer rack amp. 1 of the speakers has quit playing everything, only the woofer plays the lower ranges so it has no mids/highs or anything above 200 hz really. Ive taken it apart and verified everything is hooked up, all the speakers and tweeters test good, and nothing is burnt on the crossover or potentiometer. Other than that, i dont know much about these speakers or the crossover networks inside them. Can someone offer some help? Heres a video of a guy who has 2 in his house i found for reference.


http://www.youtube.com/watch?v=y7h5Z8A8VlA
  Reply With Quote
Old 12-05-2011, 04:50 PM   #2
Anubis
 
Anubis's Avatar

Title: I Have an Olds Life
Status: Offline
Join Date: Sep 2006
Location: Michigan
Posts: 1,971
Default Re: Kenwood KL 888X home tower 5 way speaker only playing woofer

Is there a circuit breaker for the mid and high drivers? Disconnect the drivers from the cross over and check for impedance with a mulitmeter. If they're open, there shot. Remember that dirty power (a clipped waveform) will fry high freq drivers fast. Know when your amp is reaching its limit. My Adcom GFA565 mono blocks have distortion alert indicators for this reason.
  Reply With Quote
Old 12-05-2011, 04:59 PM   #3
Bradbutlernc

Title: Banned
Status: Offline
Join Date: Aug 2010
Location: Nashville, NC
Posts: 1,666
Default Re: Kenwood KL 888X home tower 5 way speaker only playing woofer

All the coils are in spec, every thing tests good no rub etc. Is there a way to bypass the pots on the speakers? They have a "soft /normal /clear" 3 way switch with 4 wires going into the crossover board. I cant see a circuit breaker unless its on the board, and then i dont really know what im looking at. I will get some pics of the board. I usually play the reciever off a pioneer 7800mp which puts out real clean power through the RCAs, and never turned it up very loud.
  Reply With Quote
Old 12-05-2011, 07:16 PM   #4
FDWheelMan
 
FDWheelMan's Avatar

Title: Oldsmohaulic
Status: Offline
Join Date: Oct 2007
Location: Charleston, SC
Posts: 1,838
Photos: 16  Users Photo Gallery
Send a message via Yahoo to FDWheelMan
Default Re: Kenwood KL 888X home tower 5 way speaker only playing woofer

Have you tried the speakers on a different channel or a different tuner?

I'm more into vintage systems... I am running an older Sony STR-V5 on a set of older Kenwood speakers. The volume is incredible and the music is crisp clear and inviting. However, from time to time, the right channel drifts out slightly. Wiggle the volume knob and it comes back... Annoying, but when I took it to the "Best Shop in Town" I paid $150 for the idiot to run some glass cleaner over the case and give it back to me. Pissed me off. Never again! That was one of the things he was supposed to fix.

If all your speakers show being within specs, then chances are it might not be the speakers.
__________________

78 Holiday 88 - 350/350 Olds - Daily Servant & Autocross lawn dart - 133 RWHP/208 Ft/lbs Torque.
90 Mustang Coupe - 2.3/T5 - 24 Hours of LeMons Race Car
01 Mustang Bullitt - The car that was built to do all three but sits in the garage, collecting dust.
  Reply With Quote
Old 12-05-2011, 09:09 PM   #5
Bradbutlernc

Title: Banned
Status: Offline
Join Date: Aug 2010
Location: Nashville, NC
Posts: 1,666
Default Re: Kenwood KL 888X home tower 5 way speaker only playing woofer

It is the speaker. Ive swapped them on alot of different recievers. 3 work fine but the 1 is giving me trouble. All the speakers coils are in spec, and both read 6 ohms at the binding posts like theyre supposed to. I may try swapping the pots out and see if the problem could be there.
  Reply With Quote
Old 12-07-2011, 03:28 PM   #6
analogkid455
 
analogkid455's Avatar

Title: Oldsmohaulic
Status: Offline
Join Date: Feb 2005
Location: Maryland
Posts: 1,266
Default Re: Kenwood KL 888X home tower 5 way speaker only playing woofer

Quote:
My Adcom GFA565 mono blocks have distortion alert indicators for this reason
Hey I have an Adcom also with clipping lights. Mine is the 60 w.p.c. two channel amp. I use it for my satellite speakers and I use a 600 watt bridged Parasound amp for the sub. I get about 115 dB without clipping.
__________________
Erik


1987 442 Blue T-Top 1 of 1916 bone stock 250k miles and counting!
1974 Omega 468 BBO 3620# 11.85 @ 112 MPH 1.62 60ft 87 octane
http://www.cardomain.com/ride/829130

Beeterolds
Quote:
Do you take a shower and only wash one ass cheek and leave the other one filthy?
Quote:
NICE JOB GM Way to cut your own nuts off!
  Reply With Quote
Old 12-07-2011, 03:41 PM   #7
Bradbutlernc

Title: Banned
Status: Offline
Join Date: Aug 2010
Location: Nashville, NC
Posts: 1,666
Default Re: Kenwood KL 888X home tower 5 way speaker only playing woofer

Well the problem was the crossover. I ended up taking the crossovers out of two of them and replacing all the drivers except the 16" woofer. Made my own cheap crossovers using capacitors and wired pairs in series then parallel for a final load of 8 ohms at the reciever. Actually sounds better than it did before
  Reply With Quote
Reply


Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -7. The time now is 06:07 PM.

A vBSkinworks Design

 
Powered by vBulletin® Version 3.6.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
OldsPower.com 2012 Herald/Rothe